
WORKBOOK

This course is designed for those who have a basic knowledge of Microsoft Excel 
but would like to take their skills to the next level.

Of course, the term "intermediate" can be subjective.  Some who view 
themselves as beginners might use a feature that could be classified as 
'advanced', while other experienced users may be unaware of some 'basic' 
function. 

However, this short course aims to focus on topics that Microsoft does not 
include in its basic features.

As you try these exercises, think beyond the specific examples or spreadsheets 
used here and ask yourself 'how might I use this or a similar feature in my work?'

NOTE
Excel has over 450 functions and these change from time to time.  This workshop 
aims to whet your appetite to explore and search for additional features that can 
help you to manage your workload.
__________________________________________________

This OneNote notebook contains all of the exercises covered during the session.  
(A PDF version of this notebook generated by OneNote is available here).

Follow up videos are also provided to support participants after the session.

Copyright©: This notebook is only for those attending our programme and 
should not be shared or copied for other purposes.

Microsoft Excel (Intermediate)
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This programme has been tailored for Walter Scott and Partners.

A number of Excel Workbooks are included with this course, which will be 
familiar to various teams.

This data will not be used with other organisations.

You can download them here (Compressed folder).
You will then need to extract the files and move them to a suitable location.

NOTE
You may need to enable Editing on each spreadsheet

File Name

R&C Task List

Sector Check

MSCI Rank

… Back to Contents

Walter Scott and Partners
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Some of the benefits of using tables are:

Filtering and Sorting1)
Simple creation of pivot tables and charts2)
Autofill3)
Calculated columns4)
Headers (always present)5)
Totals6)
Quick formatting7)
Naming8)

… Back to Contents

Microsoft Excel has been designed to 
understand tables.

Data is laid out in a logical format that Excel 
can then easily manipulate.

Laying out data
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Let's convert our R&C Task List to an Excel table.
Open your copy of the R&C Task List (WIP2023 spreadsheet). 

Select entire table (drag your mouse or select top left cell and use "Ctrl + Shift 
+ Arrow" keys to select all columns/rows)

Now choose "Format as Table" (on this occasion, remember to check the box 
"My table has headers").

… Back to Contents

Exercise 1 - R&C Task List
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It is easier if you are creating a new Workbook and set up tables 
from the beginning.

However, it is possible simply convert existing data into a table.  

Once data is converted as a table, it is quick to filter, sort, add 
totals and more.

… Back to Contents

Tables
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NOTE
Using the same worksheet, note filters and sorting at the top of each header 
row.

Now select the "Table Design" tab and try features such as "Total Row" and 
"Slicer"

Total Row allows you to quickly add count, sum, etc. of all or filtered rows.

Note the formula (Subtotal 103,109, etc.)   It has also named the column.

… Back to Contents

Exercise 2 - R&C Task List

   Tables and Charts Page 7    



… Back to Contents

A PivotTable allows you to quickly and easily summarize and 
analyse large amounts of data by reorganizing it into a more 
meaningful and useful format.

PivotTables
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From the same worksheet in the previous exercise, select any cell from your 
worksheet table and choose the "Insert" tab.

NOTE
Before we create our PivotTable, notice the "Recommended PivotTables" 
option (Excel will attempt to suggest useful tables.  If none of these are 
suitable, we can create one manually.)

On this occasion, do not use Recommended PivotTables … Select the first 
option "PivotTable".

The pop up box will have already selected your working table.  Choose to place 
the PivotTable in a New Worksheet.

The PivotTable Fields will show to the right (these can be toggled on/off using 
the "Field List" on the PivotTable Analyze tab .

You can drag any fields between the filters, columns, rows and values.

Exercise 3 - R&C Task List
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For this example, add "Responsibility" to Rows
Add Count of Responsibility and Count of Completion Date to Values.
You can also customise the look of the PivotTable using the "Design" tab.
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… Back to Contents
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Excel supports many types of charts to help you display data in ways that 
are useful to you and your audience.

… Back to Contents

Excel allows visualisation of your data using a variety 
of interactive charts.  

This make it easier to understand large quantities of 
data and the relationship between different series of 
data. 

Graphs, Bars and Charts
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Using the same PivotTable created in the previous exercise, now select 
Recommended Charts from the Insert tab.

Choose Clustered Column

Now select the Design tab to try different colours, formatting, etc

In addition, we can create slicers.  These are similar to filters but can "float" 
anywhere on the page.

SLICER
Add slicer - using the "Responsibility" field.  Filter to show AP (hold 'CTRL' to 

Exercise 4 - R&C Task List
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Add slicer - using the "Responsibility" field.  Filter to show AP (hold 'CTRL' to 
select multiple)

Now remove filter

TIMELINES
Timelines are similar to slicers but create a filter if your model includes date-
formatted information.

Add Timeline - click on February to show all items completed in February.

… Back to Contents
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NOTE
Excel stores a date as a serial number starting at the year 1900.

1st January 1900 = 1
2nd January 1900 = 2

So 31st January 2023 = 44,957

This number will often be automatically converted back to a date format

Let's try a couple of these functions, EDATE and WORKDAY

These will calculate dates taking note of weekends and holidays.

… Back to Contents

Excel has 25 different date and time functions which can be 
useful when making -based calculations.  

A list of all functions is available on the Microsoft website.

Date functions
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Navigate to the R&C Task List (WIP 2023 worksheet)

WORKDAY

NOTE
You will see that cell T60 ("Deadline Date" column) uses the WORKDAY 
function.

=WORKDAY(E60,N60)
E60 = 31st March 2023
N60 = 10 days
WORKDAY omits weekends

So the date returned is Friday 14th April 2023

Without WORKDAY function (=E60+N60) = 10th April
Workday has missed out 2 full weekends.

WORKDAY can also omit bank holidays.

Create worksheet and name it Bank Holidays
Now copy and paste from either website:
Scotland: Public and bank holidays - mygov.scot)
OR
England: UK bank holidays - GOV.UK (www.gov.uk)

Format as table (just to practice!)

Exercise 5 - R&C Task List
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Now go back to WIP 2023 worksheet T60
Edit cell.

Add comma after N60, navigate to your new Bank Holidays worksheet and 
drag your mouse over the dates column.
Enter.
Your new formula should appear something like this:

Note that the date returned now changes to 17th April because Good Friday 
(7th April) has tipped it over next weekend.

WARNINGS
You can see the green triangles on some of the Deadline Date cells (eg. T60-
T64, but not T65-T70 etc.)

These are not necessarily errors; but at least are noted as inconsistencies 
within the column which it assumes would have the same formula.

Some cells in this column use WORKDAY, others use EDATE, etc.

EDATE

The EDATE function (also used in this column) adds a specified number of 
months to a date and returns the result as a serial date.

So T65 is =EDATE(E65,O65)
31st March 2023 + 1 month = 30th April
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As a final note on dates, Column E (Period End) contains fixed cell reference, 
$A$2.  The dollar sign makes the reference fixed rather than relative, so when 
copied to other rows or columns, the cell won't change.

The cell followed by adding a number manually (275, 348, 334, etc.)

This could be changed to a calculation if necessary.

A couple of other cells of note: 
E223 is a date with no calculation
E371 = #REF!

The #REF! error shows when a formula refers to a cell that's not valid. This 
happens most often when cells that were referenced by formulas get deleted, 
or pasted over.

… Back to Contents
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For example, =IF(A1=”Yes”,1,2) means that if the cell = Yes, the result is 
1, otherwise it returns 2).

While the IF function has been around for a long time, IFS is a newer 
function (2016) created for Microsoft 365 and is easier to use.

Let's try an example.

… Back to Contents

The IF function is popular as it allows logical 
comparisons between a value and expectations.

The IF statement can have two results. The first result is 
if your comparison is True, the second if your 
comparison is False.

IF and IFS
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Using the main R&C Task List worksheet, select cell D4.  Notice the formula is:

=IF(C4="Annual","12 months",IF(C4="Six monthly","6 months",IF(C4="Quarterly","3 
months",IF(C4="Monthly","1 month"))))

These are nested IF functions - each "IF" ends and a new one begins.  The statement concludes 
by closing each bracket separately.   The traditional IF function will still work fine especially in 
legacy versions of Excel. 

However, a new, easier option is to use the IFS function.  The above cell   

=IFS(C4="Annual","12 months",C4="Six monthly","6 months",C4="Quarterly","3 months",C4
="Monthly","1 month",TRUE,"Other")

Note the final part of the statement says that if none of the previous options are met, return 
"Other".  Only 1 bracket is needed to close the statement. 

If you ever want to check a formula, select the cell and then choose the fx options.  This breaks 
down the function arguments showing what the cell will return. 

… Back to Contents

Exercise 6 - R&C Task List
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In its simplest form, COUNTIF says:

=COUNTIF(Where do you want to look?, What do you want to look for?)

The SUMIF function syntax is similar but sums the values of cells that 
meet a criteria.  

… Back to Contents

The COUNTIF function, counts the number of cells that meet 
particular criteria.  

An example would be to count the number of times a town 
appears in a customer list.  

COUNTIF and SUMIF
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In your working spreadsheet at the bottom of the "Task Type" Column L 
(L:372), 
add a formula to keep a track of how many tasks are regulatory, routine and 
testing.

=COUNTIF(Table1[Task type],"Testing")

The search could also refer to a cell so instead of typing "Testing" this could be 
changed for K374.

… Back to Contents

Exercise 7 - R&C Task List
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Let's try these using our R&C Task List.

… Back to Contents

If needed, data in cells can be divided (or joined together) 
to use in another format.

Microsoft Excel offers features such as Text to Columns, 
Concatenate (Concat) and Remove Duplicates.

Splitting and Joining data and Removing Duplicates
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SPLITTING DATA

You may at times, especially if you've received data from a third party, need to split the 
information into multiple columns - this is a function I use frequently.

Let's try this in our R&C Task List workbook.

Create a new worksheet in the R&C Task List workbook.
Navigate to the PivotTable created earlier and Copy cells from the Responsibility field.

Paste these into your new sheet

We will now split the data (to isolate individuals rather than teams)
Select column of data 

Choose the Data tab, then "Text to columns" > Delimited > Other: /

Exercise 8 - R&C Task List
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Choose the Data tab, then "Text to columns" > Delimited > Other: /

REMOVE DUPLICATES
Columns B and C can be discarded/deleted.  You will however notice that we are left with 
some duplicate records in column A.

Now choose Data > Remove Duplicates (this is the icon next to the "Text to Columns" 
button
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Format as Table.  In next two columns manually type some First and Last names.

JOINING DATA
Sometimes you may need to join data from cells; you can do this using CONCAT.

NOTE
This is similar to CONCATENATE, an earlier function, superseded in Excel 2019 by CONCAT.

Add an additional column called Full Name. Now use formula: =CONCAT([@First]," 
",[@Last])

Let's stick with this table as we move to the next function.

… Back to Contents
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Left returns the beginning characters of a string.
Mid returns the middle characters of a string.
Right returns the ending characters of a string.

… Back to Contents

These functions extract the 
left, middle, or right portion of 
a string of text.

MID, LEFT and RIGHT
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Continuing with the previous exercised, we will use the initial letter of both the First 
and Last name columns.

Create a final column (Initials)

Use the following:

=CONCAT(LEFT([@First],1),LEFT([@Last],1))

The result is a concatenation of the left hand side character in the First name column 
and the left hand side character in the Last name column.  Increasing the number in 
the argument, adds additional letters to the string.

… Back to Contents

Exercise 9 - R&C Task List
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VLOOKUP matches vertically (by columns)
HLOOKUP (matches horizontally (by rows)
XLOOKUP (matches both - released in 2019 is simpler and more powerful 
to use).

I would recommend using XLOOKUP.

NOTE 
XLOOKUP requires Microsoft Excel 2021 or later, Excel for MS365, Excel 
Online or Android/iOS.  
For earlier versions of Excel, please use VLOOKUP/HLOOKUP

… Back to Contents

The LOOKUP functions allow Excel to reference a 
cell to match values in another row or column 
against the cell and thereby retrieving the 
corresponding results from the respective rows 
and columns.

VLOOKUP, HLOOKUP and XLOOKUP
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We are now going to use the MSCI Val Rank Excel file.

NOTE 
This file is generated by a third party and is not in an ideal Excel format.

Subtotals are at the top of each sector. •
The Company and Sector data are in the same column.•

Let's create a new format of the data that Excel can easily manipulate.  The next 
time the data is provided, you can copy and paste your new data and your 
XLOOUP sheet will read it and return an Excel-friendly format.

To save time, I've created a worksheet "Data - XLOOKUP" and manually 
populated column A with sector (originally in the same column as company).
I've also manually added all the companies (using copy and paste) in column B.

Let's pull dynamic information from our "Original Data" worksheet into our new 
format.

Note cell A1 is pulling data from our original sheet A2).  This will update each 
time you paste your new month's data.

Now select cell C3.  Edit the cell to begin with =XLOOKUP

Note the cell helps you to identify the arguments:

Now paste the following in your formula
=XLOOKUP($B4,'Original Data'!$A$5:$A$59,'Original Data'!B$5:B$59,"Not 
Found")

As an aside, selecting the fx function symbol in any cell will present a step by step 
wizard (showing you what will be returned in the cell as you edit the parameters).

Exercise 10 - MSCI Val Rank
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NOTE
From our above example, please notice Absolute vs Relative cell references.  The 
$ symbol creates an absolute reference (row, column or both).  This reference 
will be fixed and not change when you copy the formula into adjacent cells.

=XLOOKUP($B4, - note absolute column and relative row in what it searches for.  
When we copy it down, it will move to each row but only look in column B

=XLOOKUP($B4,'Original Data'!$A$5:$A$59,' - this cell range (row and column) is 
absolute.  When we copy it down it will still search the exact same cells.  
=XLOOKUP($B4,'Original Data'!$A$5:$A$59,'Original Data'!B$5:B$59, this cell 
range has a relative column but absolute row.  When we copy this across to other 
columns it will return the relevant columns

The first 3 elements are required:

Lookup value - what to search for1)
Lookup array - where to search2)
Return array - what to return3)

There are also optional elements:

If not found - what to return if no match is found1)
Match mode - whether the match should be exact or similar4)
Search mode - whether to search up first, or down, etc.5)
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Benefits of this approach
Data is now stored in an Excel-readable format.
Pivot tables/charts are easy to create and maintain
The next time the data is updated/downloaded - simply copy and paste the data 
into the same original data sheet.

Older versions of Excel
To accomplish the same thing in Excel 2019 or earlier use VLOOKUP

=VLOOKUP([@COMPANY],'Original Data'!A5:G60,2,FALSE)

… Back to Contents
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One of the most common data validation uses is to create a drop-down list.

… Back to Contents

Data validation restricts the type of data 
or values that users enter into a cell. 

This provides consistency and reduces 
errors.

Data validation
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To avoid errors, it can be worthwhile limiting the data that users can enter.
For this exercise, please revert to the R&C Task List.  Note column C (Frequency).

The data used here is Monthly, Quarterly, Quarterly, Six monthly, Annual.  
This affects column D (Period Covered).  See earlier Exercise 6 - R&C Task List.

If someone typed "Annually" instead of "Annual", the column D formula will break.
So to limit the entries, we can use Data Validation.

Create a new worksheet (called Frequencies).  In this sheet type the frequencies in 
separate rows:

Monthly
Quarterly
Six Monthly
Annual

In the main working sheet, select the first cell in the Frequency column (likely C4)
Choose: Data>Data Validation

In the settings change to List
In the Source, choose the Up arrow and select cells from your new Frequencies sheet
Add any input or warning messages.  Choose OK.

Exercise 11 - R&C Task List
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NOTE
We now need to copy the data validation to all the other cells in the column.  
However, if you use the standard copy and paste, all the contents will change as well.

Instead, select the top cell, choose copy.  Now select all the cells below and choose 
Paste Special > Validation.  This will maintain the original data, but will protect the 
cells with data validation.

… Back to Contents
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Here are just a few examples of how it can be used:

You can use conditional formatting to highlight cells that contain values 
which meet a certain condition. 

Or you can format a whole cell range and vary the exact format as the value 
of each cell varies.

Temperature information with conditional formatting applied that shows top 
10% and bottom 10% values.

… Back to Contents

Conditional formatting makes it easy to highlight certain 
values or make particular cells easy to identify. 

This changes the appearance of a cell range based on a 
condition (or criteria). 

Conditional Formatting
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Open the Sector Check workbook.  For this example, we will create a visual check that 
our portfolio fund is within a tolerance of the relevant benchmark.  Insert a new row 
above the main tables for tolerance (this will be a percentage over the benchmark).  

NOTE
We will only create a single cell (the same check for each fund).  However, each fund 
could have their own tolerance.

Now select the first column of investments (column B12:B23)

Choose the Conditional Formatting button on the Home tab.  Choose to create a New 
Rule.

Select the 2nd option, "Format only cells that contain"
In the cell value, select "less than or equal to" -and type =C12+$B$4 (note relative and 
absolute references).  Now format it to Green, etc.  Choose Ok and Apply.

Exercise 12 - Sector Check
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Now go back to Conditional Formatting and select "Manage Rules".  Duplicate the rule 
you have just created, edit the copy and change the condition to "greater than".  Change 
the formatting to Red, etc.  Now apply and close the rule.

Now adjust the tolerance to see the cells highlight those higher than the allowed range.

Cheat: if you wish to apply this conditional formatting to the entire sheet,  copy the 
following code into the "Applies to" fields (both the red and green rules): 

=$AX$11:$AX$23,$AV$11:$AV$23,$AT$11:$AT$23,$AR$11:$AR$23,$AP$11:$AP$23,$AN
$11:$AN$23,$AL$11:$AL$23,$AJ$11:$AJ$23,$AH$11:$AH$23,$AF$11:$AF$23,$AD$11:
$AD$23,$AB$11:$AB$23,$Z$11:$Z$23,$X$11:$X$23,$V$11:$V$23,$T$11:$T$23,$R$11:
$R$23,$P$11:$P$23,$N$11:$N$23,$L$11:$L$23,$J$11:$J$23,$H$11:$H$23,$F$11:$F
$23,$D$11:$D$23,$B$11:$B$23

Any time your file data is regenerated, you can paste the new data into this sheet with 
conditional formatting.
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________________________________________________________________________
____________

NOTE 
VBA and Macros are included in this file.  For security purposes, this may be disabled or 
the script may be missing)

… Back to Contents
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To remove the risk of errors appearing in our 
spreadsheets, especially when shared with other users, 
consider password protecting your data.

You can still leave some cells unlocked to allow for editing, but locking 
complicated formulas
to maintain the security of the spreadsheet data.

… Back to Contents

Protecting data
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Open the R&C Task List workbook

Let's assume you want to lock the entire spreadsheet apart from the 
"Reviewed by", "Checked by", "Completion Date" which can be updated by 
team members.

Select these entire columns and format the cells (columns Q,R,S).

Choose Home tab, Format, Format cells, choose the "Protection" tab and 
uncheck "Locked"

OPTIONAL
To highlight unprotected cells, create conditional formatting to highlight 
them.

Select the top left cell of the table (A3)
Choose Conditional Formatting
Use a Formula to determine which cells to format
In the formula, type =CELL("Protect",A3)=0     Note: change =0 to =1 to 
highlight protected cells.
Select some formatting (e.g. yellow background).
Choose Ok.  

Exercise 13 - R&C Task List
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Choose Ok.  

You will likely need to edit the rule to make sure "Applies to" selects at least 
all the unprotected cells.  As a cheat, the "Applies to" should read =$A$4:$W
$372

Choose Apply and Ok

___________________________________________________________

Now select the Review tab > Protect Sheet.
Ensure "Select Unlocked Cells" is checked and use a memorable password 
(suggested "walterscott").  You will need to re-enter it after clicking "OK".
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All other cells will now be protected.  To unprotect the sheet, reverse the last 
process.

… Back to Contents
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